Connectivity Issues
Incident Report for KornitX
Postmortem

Incident Report

Incident Reference: 92792

Incident Overview

Outage of Kornit X Platform including Web Tier, Order Creation and Background Processing

Date/Time identified

05/11/2022 10:13 GMT

How was the issue identified?

  • Various alerts were raised by the Kornit X system monitoring regarding failed connectivity with the Platform.

What Date / Time was the service to customers first affected?

05/11/2022 10:06 GMT

What was the impact?

All Kornit X core order services were unavailable –

Including:

  • Order creation and background processing of orders.
  • Web tier meaning users were unable to view and manually process orders, download artwork, complete production tasks
  • API services unrelated to order processing

Excluding:

  • Front end Smartlinks that did not featuring pricing or stock data

What was done to restore service?

  • VPN tunnel restarted which resolved the issue

What time was service restored?

05/11/2022 11:06 GMT

What caused the service to fail?

  • Two instances of the same VPN tunnel were running at once, which caused communication issues within our network.

Are there any further actions?

  • We are investigating further into what caused the second instance of the VPN tunnel to become active and how this can be prevented from happening again.
  • This VPN will be decommissioned once Kornit has completed the migration of all Kornit X Platform services to AWS Cloud Infrastructure, targeted for Q1 2023.
Posted Nov 05, 2022 - 12:41 UTC

Resolved
Connectivity has now been restored and all systems are now operational.

We will provide additional details in due course.
Posted Nov 05, 2022 - 11:07 UTC
Update
We are continuing to investigate this issue.
Posted Nov 05, 2022 - 10:35 UTC
Investigating
We are currently experiencing a network issue that is affecting our services.

We are investigating the issue and will provide an update as soon as possible.
Posted Nov 05, 2022 - 10:34 UTC
This incident affected: Platform Core (London - UK).